FC2ブログ


●○スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。



●○xineで動画再生

20041207000252.pngDVDプレイヤーとしても使える「xine」のインストール方法です。


ダウンロード
「xine」から「xine-lib-1.0.tar.gz」と「xine-ui-0.99.3.tar.gz」をダウンロードします。
次にコーデック「essential-20050115.tar.bz2」を「MPlayer」からダウンロードします。


インストール
解凍
$ tar xfz xine-lib-1.0.tar.gz
$ tar xfz xine-ui-0.99.3.tar.gz
$ tar xfj essential-20050115.tar.bz2

コーデックを移動
$su
*******
# mv essential-20050115 /usr/local/

インストール
$ cd xine-lib-1.0
$ ./configure --with-w32-path=/usr/local/essential-20050115 && make
$ su
*******
# make install

$ cd ../xine-ui-0.99.3
$ ./configure && make
$ su
********
# make install

システム設定 (rootのまま)
# vi /etc/ld.so.conf
/usr/local/lib (あらたに追記)
# /sbin/ldconfig


「Vine」での注意
下のコメントの欄にもありますが、「Vine Linux」では一部のライブラリがなくて、「./configure」でエラーになるようです。
「DVDを見よう! (xineの導入)」で、詳しく解説されている方がいらっしゃいます。
「Vine Linux」をお使いの方は、ご注意ください。


DVD再生
$ xine dvd:///dev/hdc
「udev」の導入で「/dev/dvd」がないので、DVDドライブを接続しているデバイスファイルを指定する。
この場合は、「/dev/hdc」に接続している。

スポンサーサイト

>> 2005/02/20 12:08
xine-ui-0.99.3をconfigureする前に
システム設定を行なわないとエラーが
発生します.

>> 2005/03/07 12:48
指摘、ありがとうございます。
「configure」のオプションを指定する必要があるという事だと思います。
もしくは、/etc/ld.so.conf の書き換えが必要だったのかもしれません。

インストールしたのが昔の事だったので、わすれてました。

>> 2005/04/19 18:06
このコメントは管理人のみ閲覧できます

>> 2005/04/19 18:09
すみません。
xineのインストールのしかたで質問します。
vine3.1をインストールした状態です。

$ cd xine-lib-1.0
$ ./configure --with-w32-path=/usr/local/essential-20050115 && make

>configure: error: zlib needed
>[root@localhost xine-lib-1.0]# make install
>make: *** ターゲット `install' を make するルールがありません。中止。

が表示されて、make installできません。
vine 2.6の時は何もしなくてinstallできたのですが。
大変すみませんが、解決策を教えて下さい。

>> 2005/04/19 22:18
>configure: error: zlib needed

DVDを見よう! (xineの導入)
http://shino.pos.to/linux/xine.html

Vine Linux 3.0で必要な追加パッケージ
2. zlib-devel

とあります。
おそらく、「ZLIB」がインストールされていないのでしょう。

ftp://ftp.kddlabs.co.jp/pub/Linux/packages/Vine/Vine-3.1/i386/Vine/RPMS.devel/

に「zlib-devel」のRPMがあります。

ftp://ftp.kddlabs.co.jp/pub/Linux/packages/Vine/Vine-3.1/i386/Vine/RPMS.main/

にも「zlib」のRPMがあります。

「zlib-devel」と「zlib」のどちらにするべきかは分かりませんが、おそらく後者のほうを選んでインストールすると良いのではないかと、思われます。
もし、ダメなら「zlib-devel」に入れ直したら良いかと。

私は「Vine」をさわった事がないです。
ですので、上の内容で解決するかどうかも分かりませんが、お役にたてれば幸いです。

>> 2005/04/20 18:09
configureする時は、develパッケージが必要になるみたいですので、
zlib-develが必要と思います。もしかしたらzlibも必要かもしれません。
最初はそれを知らずに、結構はまりました。

>> 2007/01/05 14:21
このコメントは管理者の承認待ちです

>> 2007/01/05 14:23
このコメントは管理者の承認待ちです

>> 2007/02/06 04:42
このコメントは管理者の承認待ちです

>> 2007/02/06 06:57
このコメントは管理者の承認待ちです

>> 2007/02/06 07:00
このコメントは管理者の承認待ちです

>> 2007/02/06 07:02
このコメントは管理者の承認待ちです









ブログ管理人にのみ表示を許可する


trackback
trackback_url
http://moom6.blog2.fc2.com/tb.php/14-714a8ec4

[TOP]
copyright (C) 2006 Linuxとかのメモ all rights reserved. [ template by *mami ]
//
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。